Web lists-archives.com

Re: Open beta of debhelper compat level 11 (debhelper/10.10.7)




On Sun, Nov 12, 2017 at 10:25:00AM +0000, Niels Thykier wrote:
>...
> Full list of changes in compat 11
> =================================
>...
> >         -       The cmake buildsystem now passes
> >                 -DCMAKE_INSTALL_RUNSTATEDIR=/run to cmake(1).
> > 
> >                 Caveat: This option silently does nothing in cmake versions
> >                 prior to 3.8. Please keep this in mind if your package is
> >                 regularly backported to a suite (e.g. stretch-backports)
> >                 where cmake is older than 3.8.
>...
> Backport availability
> =====================
>...
> *Caveat*: Packages using the cmake build system should be careful as
> cmake in stretch does not respond to the
> -DCMAKE_INSTALL_RUNSTATEDIR=/run change in compat 11.  If this is a
> problem for your package, the package should probably stay at compat 10
> until buster is released.

Is anything preventing a backport of cmake to stretch-backports?

This would allow debhelper to add Breaks on older cmake versions,
which would also automatically handle all backports situations
in a correct way.

> Thanks,
> ~Niels

cu
Adrian

-- 

       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed