Web lists-archives.com

Re: Anyone using stretch/buster/sid on ARMv4t ?




std::future was fixed a while ago by upstream. It now works on any target even when there are no lock-free atomics in hardware.


Btw, prior that, you would actually need at least ARMv7.

Adrian

On Nov 9, 2017, at 6:40 PM, Sune Vuorela <nospam@xxxxxxxxxx> wrote:

On 2017-11-07, Adrian Bunk <bunk@xxxxxxxxxx> wrote:
This whole "so many packages are broken on armel" narrative
is actually mostly FUD, and you are suggesting mitigations
for a nonexisting problem.

Have we gotten full c++11 support on armel yet ?

(future, atomic, ...)

/Sune