Web lists-archives.com

Bug#875987: ITP: node-babel-plugin-transform-decorators-legacy -- Compile class and object decorators to ES5 (legacy)




Package: wnpp
Severity: wishlist
Owner: Daniel Ring <dring@xxxxxxxxxxxx>
X-Debbugs-CC: debian-devel@xxxxxxxxxxxxxxxx

* Package name    : node-babel-plugin-transform-decorators-legacy
  Version         : 1.3.4
  Upstream Author : Logan Smyth <loganfsmyth@xxxxxxxxx>
* URL             : https://github.com/loganfsmyth/babel-plugin-transform-decorators-legacy#readme
* License         : Expat
  Programming Lang: JavaScript
  Description     : Compile class and object decorators to ES5 (legacy)

 A plugin for Babel 6 that (mostly) replicates the old decorator behavior from Babel 5.

 Babel is a JavaScript compiler to use next generation JavaScript, today.

 ES2015 and beyond: Babel has support for the latest version of JavaScript
 through syntax transformers. These plugins allow you to use new syntax, right
 now without waiting for browser support.

 Note: This library is in contrib because it needs node-babel from contrib to
 build.

 Node.js is an event-based server-side JavaScript engine.