Web lists-archives.com

Re: what should I do if I want to adopt one orphaned package?




On 2017-08-11 15:19 +0000, 慕 冬亮 wrote:


> Dear all,
> 
>     I want to adopt one package - Bochs [bochs: IA-32 PC emulator (package info
> )] which is orphaned since 2011 days. And the current version in sid is 2.6-5.

Good to hear, thank you.
 
>     The official website shows that the latest version of Bochs is 2.6.9. And
> the history for bochs is as follows:
> 
>   • May 3, 2015: Bochs 2.6.8 is now available.
>   • November 2, 2014: Bochs 2.6.7 is now available.
>   • June 15, 2014: Bochs 2.6.6 is now available.
>   • June 1, 2014: Bochs 2.6.5 is now available.
>   • May 26, 2013: Bochs 2.6.2 is now available.
>   • April 7, 2013: Bochs 2.6.1 is now available.
>   • September 2, 2012: Bochs 2.6 is now available.
> 
>     What should I do and which document should I read in advance?

https://www.debian.org/doc/manuals/developers-reference/ch05.en.html#archive-manip
specifically 5.9.5.

Did you already try to contact the previous maintainer?
Are they on this list:
https://wiki.debian.org/LowThresholdAdoption

If it's been orphaned for 5 years I think you are safe to just update
and upload it, but policy says you should try to contact the previous 
maintainer to get an OK. More details are at:
https://www.debian.org/doc/manuals/developers-reference/ch07.en.html#mia-qa

>     I have been using Debian for three years. I have some knowledge about
> Debian package development. I only have a little experience in debian software
> packaging.

The policy document and debian-mentors mailing list can help you with
packaging queries. When you have a new upload prepared you will need
to get a sponsor to upload by asking on debian-mentors.

Wookey
-- 
Principal hats:  Linaro, Debian, Wookware, ARM
http://wookware.org/

Attachment: signature.asc
Description: Digital signature