Web lists-archives.com

Re: Embedded library copies - mergerfs




On Mon, Aug 7, 2017 at 8:30 AM, Antonio SJ Musumeci wrote:

> My users span several generations of Debian (and other) Linux distributions.
> Early 2.9.X versions of libfuse had bugs which led to "random" crashes.
> These versions are still in wide use (I get 2.8.x users on occasion too).
> Over past couple years I've spent countless hours tracking down issues
> related to these buggy versions and helping (often inexperienced) users
> upgrade their systems. This is the core reason I decided to embed libfuse
> 2.9.7 into mergerfs.

If faced with this situation myself, personally I think I would have
marked those versions of libfuse as explicitly unsupported using both
build and run time checks. People building from source would then need
to backport libfuse before updating mergefs.

-- 
bye,
pabs

https://wiki.debian.org/PaulWise