Web lists-archives.com

Re: sse{2,3,4.2}, altivec, neon, ...




On 08/07/2017 12:15 PM, Adrian Bunk wrote:
> Packages that genuinely cannot work on the architecture baseline are
> very rare, these are a tiny part of the packages that are not binary-any.

In general I agree with you that we should not allow too much
fragmentation. I suppose at the point where we'd allow dependency on
meta-packages for architectural support we'd also make them work on the
buildd infrastructure somehow[1]. Otherwise you can't run test binaries.

What was pretty frustrating is the requirement of Go to have a much
higher architectural baseline on s390x. To the point that I already
considered raising the baseline and at least retiring the builder that
does not support the higher architectural requirement. You end up with a
lot of packages being technically unbuildable and unrunnable on older
machines.

Kind regards
Philipp Kern

[1] Which isn't trivial as the dependency on *-support can be satisfied
by wanna-build but it'd then (supposedly) fail to build and it's not
clear which builder would support which feature set.