Web lists-archives.com

Re: Bits from the 10th Debian Groupware Meeting




Hi Martin,

thank you for all the links.  My main question was why it is not listed at all 
in the groupware wiki, you could easily list nextcloud/owncloud in the section 
"Groupware projects not currently considered for inclusion in Debian".

I always had the impression that part of the motivation for owncloud to 
collaborate with downstream, that owncloud wanted to preserve their business 
model to sell enterprise support.

For the technical part, I am wondering if that is still a real issue. I see 
the latest version 12.0.0 was released at May 22 2017, since then there was 
not even a bugfix release. Before, I remember that I have seen much shorter 
release cycles.

So I can see multiple solutions
1) Debian includes nextcloud only in unstable and testing (probably most 
compatible with the nextcloud/owncloud business models, see also https://
help.nextcloud.com/t/will-nextcloud-be-inviting-to-distribution-packages/89/28 
)
2) If Nexcloud is interested to bring their software into the debian repo, 
they can help run their regression tests on the upgrade path implemented for 
Debian stable releases (which happens infrequently)
3) If only Debian is interested to have nextcloud, assuming that there are 
only 1-2 major nextcloud releases within a Debian release, Debian might be 
able to handle the upgrade path.

Kind regards
Rainer

Am Donnerstag, 3. August 2017, 14:07:29 CEST schrieb Martin Steigerwald:
> Hello Rainer.
> 
> Rainer Dorsch - 03.08.17, 13:12:
> > Hi Guido,
> > 
> > just wondering, did you consider nextcloud as groupware?
> 
> Owncloud has been in Debian… and its past maintainers gave up on maintaining
> it. For a part of the discussion see:
> 
> Debian Bug report logs - #822681
> RM: owncloud -- ROM; Unfit upstream, uninstallable
> https://bugs.debian.org/822681
> 
> [Pkg-owncloud-maintainers] Removing owncloud from jessie?
> https://lists.alioth.debian.org/pipermail/pkg-owncloud-maintainers/2017-Marc
> h/ 003200.html
> 
> [Pkg-owncloud-maintainers] You want users to lose data?!?!
> https://lists.alioth.debian.org/pipermail/pkg-owncloud-maintainers/2016-Febr
> uary/002881.html
> 
> 
> [Pkg-owncloud-maintainers] Bug#815963: Warn users about unsupported upgrade
> path
> [Pkg-owncloud-maintainers] Upstream making our life more and more painful
> (Was: [owncloud-devel] Bug#815963: Warn users about unsupported upgrade
> path)
> https://lists.alioth.debian.org/pipermail/pkg-owncloud-maintainers/2016-Feb
> ruary/002872.html
> 
> Debian Bug report logs - #815963
> Warn users about unsupported upgrade path
> https://bugs.debian.org/815963
> 
> I think unless there are significant changes in how upstream handles
> updates… or… in the way how Debian handles webapps it may be difficult to
> find a maintainer for official Nextcloud Debian packages.
> 
> Thank you,


-- 
Rainer Dorsch
Beatus-Widmann-Str. 5
72138 Kirchentellinsfurt
07157-734133
email: fdbaut@xxxxxxxxxxx