Web lists-archives.com

DocBook 5 for Debian





I am creating a new XSLT file to convert DocBook 5 "refentry" (man page) files to texinfo files on a non-Debian system.  I would like to bring DocBook 5 into Debian.

DocBook 5 has incompatibilities with DocBook 4.x, so the two versions would have to co-exist.  I wanted to discuss this here before filing any ITPs, etc., to solicit opinions from those who would be interested and affected.  Obviously, nothing new should impact anybody using DocBook 4.5 on Debian.

You can read about changes from DocBook 4.5 to DocBook 5.0 here:

http://tdg.docbook.org/tdg/5.0/ch01.html#introduction-whats-new

In general, each major revision of DocBook can introduce backwards-incompatible changes from earlier versions.  The DocBook Technical Committee of OASIS intended that no major release would introduce incompatible changes unless such changes had been announced in the previous major release.  However, they made an exception for DocBook 5 with its shift to a RELAX NG and Schematron-based definition versus a DTD definition.  Thus, package names of the form "docbook5" and "docbook5-*", "docbook6" and "docbook6-*", etc. seem appropriate for new packages (although DocBook 6.0 is not expected to introduce backwards-incompatible changes from DocBook 5.x because no such changes were announced at the release of DocBook 5.0).

DocBook 5 DTDs are also available for XML and SGML, but they do not fully define the syntax of a DocBook 5 file--the RELAX NG and Schematron definitions do.

I think this inclusion of the major version number in the package name should also apply to XSL packages, because XSLT files will be written for a specific major version of DocBook.  This implies that a DocBook 5 collection of XSL files will exist that will have a lot of overlap with the existing docbook-xsl package under a different name.  There is also an XSLT file for transforming DocBook 4.5 files into DocBook 5.0 files, which would be included in a proposed "docbook5-xsl" package.

I do not want to adopt the orphaned DocBook 4.x packages, because they are not being updated upstream.  I might consider updating them in the future for new Debian Standards versions, but my focus is on working with DocBook 5.

I would also intend to make the HTML5 entity definitions for special character names available for DocBook 5 use ("—", "–", etc.).  I think that would be appropriate for a "docbook5-xml" package.

Therefore, I propose filing ITPs for packages "docbook5", "docbook5-xsl", and "docbook5-xml".  The packages initially would be based on DocBook 5.1, unless DocBook 5.2 is finalized in the meantime.

Any comments or suggestions?

Thank you,


Paul Hardy