Web lists-archives.com

Re: Future cme dpkg changes about versioned dependencies




On Mon, 17 Jul 2017 20:05:12 +0200, Dominique Dumont wrote:

> Some parameters exists that let user decide whether the "cut-off" should be 
> done for stable or old-stable.

I vaguely remember setting this somewhere long ago ...

*after quite some time*

% cat ~/.dpkg-meta.yml 
---
dependency-filter: lenny
group-dependency-filter:
  'Debian Perl Group <pkg-perl-maintainers@xxxxxxxxxxxxxxxxxxxxxxx>': lenny

Haha.

(Interesting detail: last modified 2017-07-02 ?!)
 
> The possibility to choose between old-stable and stable has been broken for 
> quite a while and nobody complained. 


Because of

      'dependency-filter',
      {
        'choice' => [
          'etch',
          'lenny',
          'squeeze',
          'wheezy'
        ],

in lib/Config/Model/models/Dpkg/Meta.pl?

> I guess that nobody uses this feature, so 
> I'm going to remove it. (it's one of those "cool" feature that nobody actually 
> cares about, oh well... )

It seems at least you and me cared about it years ago :)
But I agree that it didn't turn out to be so helpful as apparently I
completly forget about the file.
 
> Unless someone has a better idea, I plan to implement a simpler ruler: a 
> warning will be issued only for dependencies requiring a version older than 
> the oldest one known by madison.

Excellent, that would have been exactly my suggestion.


Cheers,
gregor

-- 
 .''`.  https://info.comodo.priv.at/ - Debian Developer https://www.debian.org
 : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D  85FA BB3A 6801 8649 AA06
 `. `'  Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe
   `-   NP: Sinéad O'Connor: The Healing Room

Attachment: signature.asc
Description: Digital Signature