Web lists-archives.com

perl versioned Provides no longer in sid




On Mon, Jul 03, 2017 at 01:43:53PM +0300, Niko Tyni wrote:
> On Sun, Jun 18, 2017 at 09:26:31PM +0300, Niko Tyni wrote:
>  
> > As discussed in #758100, I'd like to switch to using versioned Provides
> > in perl/perl-base/perl-modules-5.xx for buster. I'd be interested to
> > hear if anybody knows of any remaining blockers for that.
> 
> [...]
> 
> > My current thinking would be not to couple this change with the future
> > Perl 5.26 transition, so I'm planning to push this into sid (= the 5.24
> > packages) soonish. Unless there's a reason not to?
> 
> This is now done in unstable with perl/5.24.1-5.

... and reverted in perl/5.24.1-7, mostly because of #867104 (wanna-build
not considering a real and a versioned virtual package with the same name
co-installable, leaving several packages at B-D-Uninstallable due to no
fault of their own), and partly because of #867081 (autopkgtest problems.)

We can revisit this if/when these new blockers are fixed.
-- 
Niko Tyni   ntyni@xxxxxxxxxx