Web lists-archives.com

perl versioned Provides now in sid




On Sun, Jun 18, 2017 at 09:26:31PM +0300, Niko Tyni wrote:
 
> As discussed in #758100, I'd like to switch to using versioned Provides
> in perl/perl-base/perl-modules-5.xx for buster. I'd be interested to
> hear if anybody knows of any remaining blockers for that.

[...]

> My current thinking would be not to couple this change with the future
> Perl 5.26 transition, so I'm planning to push this into sid (= the 5.24
> packages) soonish. Unless there's a reason not to?

This is now done in unstable with perl/5.24.1-5.

The fallout so far is #866991 which seems to be a mostly isolated issue.
Please let us know (via debian-perl@ldo, perl@pdo or otherwise) if other
issues emerge.
-- 
Niko Tyni   ntyni@xxxxxxxxxx