Web lists-archives.com

versioned Provides status




[bcc'd -release as a heads-up, but I guess this should stay on -devel]

Hi, and thanks to everybody who contributed to the stretch release!

As discussed in #758100, I'd like to switch to using versioned Provides
in perl/perl-base/perl-modules-5.xx for buster. I'd be interested to
hear if anybody knows of any remaining blockers for that.

The change is already in place in experimental for the Perl 5.26 packages,
and our test rebuilds indicate things seem to be working OK. The issues
on the archive / infrastructure side that I'm aware of have been fixed:

 - britney support has been in place for a year (#786803)

 - wanna-build should be fine with the dose3 in stretch (#786671)

There's an open policy bug about this in #761219. I see a dozen or so
packages (mostly PHP related) in sid already seem to be using versioned
Provides, so the archive does seem ready, but I'm trying to play it
safe with such core packages as the src:perl ones.

My current thinking would be not to couple this change with the future
Perl 5.26 transition, so I'm planning to push this into sid (= the 5.24
packages) soonish. Unless there's a reason not to?
-- 
Niko Tyni   ntyni@xxxxxxxxxx