Web lists-archives.com

Re: Too many Recommends (in particular on mail-transport-agent)




Using you script, it doesn't seem to be too bad. I went through a few machines:


I went through the ones on my desktop here (running testing). Excluding non-Debian packages, I found:

blktrace Recommends: libtheora-bin, libav-tools, librsvg2-bin

   I suspect these are required for iowatcher (one of the three tools
   in the package) to run. I personally just use blktrace and blkparse;
   I think it's reasonable if the maintainer considers iowatcher
   important as well. But it is a huge dependency chain, especially for
   libav-tools (which nowadays is a transitional package for ffmpeg).


firmware-linux Recommends: amd64-microcode
firmware-linux-nonfree Recommends: amd64-microcode

   This machine has an Intel CPU. It should probably recommend
   intel-microcode | amd64-microcode instead of both. Though we are
   talking about an Installed-Size of 68 here.


geoclue-2.0 Recommends iio-sensor-proxy, modemmanager, wpasupplicant

   My desktop has none of this hardware. Network is wired Ethernet. It
   does have temperature sensors, though I doubt the CPU temperature is
   too useful for finding my location. (Given, geoclue is probably
   pretty useless on my box.)


get-flash-videos Recommends: get-iplayer

   I don't live in the UK, and AFAIK iplayer is geo-restricted to the UK.

vlc Recommends: vlc-plugin-samba (and a few others)

   Note this plugin is only needed to access Samba shares that aren't
   mounted (it's samba client in userspace). Seems like it's perfectly
   reasonable to only play mounted videos, or ones from network
   streams. VLC has a few more plugins in Recommends that I have installed.


There are various packages that Recommends: their -doc packages; those probably sense if you've installed them directly, but are annoying when the package has come in as a dependency.

There are of course a bunch more unsatisfied recommends, but they don't strike me as weird (e.g., where I've elected not to install -i18n packages).



On a home server, running Jessie—the script failed ("AttributeError: 'Dependency' object has no attribute 'installed_target_versions'"). I don't know enough (any) Python to fix it.


On another desktop (at work) running testing (and ignoring ones already mentioned above):

hplip Recommends: sane-utils

   Printer is just a printer. Doesn't have a scanner.

libsane Recommends: sane-utils >= 1.0.25-4.1

   Don't have a scanner. (libsane is pulled some Depends). AFAIK -util
   is some programs to use SANE, not things called by the library.

openvpn Recommends: easy-rsa

   Unsure about this one. I have it a bunch of places, but the average
   person probably doesn't want to use the OpenSSL command line. Though
   certificate management is a once every X years problem, except on
   your CA.