Web lists-archives.com

Re: [E-devel] EFL 1.19.0-beta3 (from git) package for Debian Experimental




On Mon, Mar 20, 2017 at 04:44:53PM -0700, Jose R R wrote:
> On Mon, Mar 20, 2017 at 1:19 PM, Ross Vandegrift <ross@xxxxxxxxxxx> wrote:
> >
> > On Sun, Mar 19, 2017 at 11:47:39PM -0700, Jose R R wrote:
> > > https://git.enlightenment.org/core/efl.git/
> > >
> > > Notwithstanding, I intended to package Enlightenment and make download
> > > available for my SourceForge Debian-Reiser4 netboot installer.
> > >
> > > EFL debian packaging:
> > > http://http.debian.net/debian/pool/main/e/efl/efl_1.18.4-1.debian.tar.xz
> >
> > Any reason you want to rebuild from git instead of using the packages in
> > experimental?  If you've found a problem, I'd like to fix it.  On sid &
> > stretch they should install without difficulty.
> 
> I will try anything, until something works. Then I will proceed to
> work on the backport for the stable Debian (Jessie) to complement
> Reiser4 kernel, backported{ linux-base, nfs-common, reiser4progs
> (reiser4 fs utilities), etc.}. If I install packages directly from
> Debian unstable(Sid), testing (Stretch), or -- in this particular
> case, experimental -- repositories onto stable/Jessie-backports, the
> end user will end up with dependency hell, i.e, broken installation.

Oh I see - I misunderstood your previous message and thought you were
targeting sid.  You need to backport + rebuild for jessie.  IIRC, the
only change I needed was to remove the auto dbgsym stuff.

[snip]
> FAIL: tests/evas/evas_suite
> ===========================
> 
> /mnt/caxtolli/usr/src/build/enlightenment-debian/sid-omeyi/efl-1.18.4/src/tests/evas/.libs/evas_suite: symbol lookup error: /mnt/caxtolli/usr/src/build/enlightenment-debian/sid-omeyi/efl-1.18.4/src/lib/efl/.libs/libefl.so.1: undefined symbol: _eo_call_end
> FAIL tests/evas/evas_suite (exit status: 127)

This seems suspicious - the linker can't find a symbol in libefl.so.
Are you building with some other patches?

[snip]
> FAIL: tests/eio/eio_suite
> =========================
> 
> Running suite(s): Eio
[snip]
> 98%: Checks: 51, Failures: 1, Errors: 0
> tests/eio/eio_test_manager.c:68:F:Eio Job:efl_io_manager_test_ls_funcs:0: Failure '(*number_of_listed_files) != test_count' occurred

I don't recall seeing this test fail before, sorry.

Ross