Web lists-archives.com

Re: Post-stretch mass bug filing: build-depending on automake1.11




On Wed, 15 Mar 2017 at 00:03:21 +0200, Adrian Bunk wrote:
> The relevant question is whether there is a non-zero amount of packages 
> where a 1.11 -> 1.15 switch would be hard.

Yes. Based on my admittedly hazy recollections of upgrading the Autotools
build systems in upstream projects across that range, the main problem
is likely to be the switch from the serial test harness to the parallel
test harness as default - but that's easier now than it was when moving
to Automake 1.13, because it should be acceptable by now to hard-require
a modern version (one that offers the serial-tests option for instance)
rather than going to great lengths to support both.

> One important package that is hard to convert to 1.15 could be enough to 
> keep automake1.11 even in buster (we have 5 different autoconf versions 
> in stretch...).

I'm hoping that won't happen, but we'll see. I too am saddened by the
number of autoconf versions in the archive.

> >...
> > A couple of these packages build-depend on
> > automake (>= 1.11) | automake1.11, but to be honest they'd probably be
> > better off with just automake (>= 1.11) anyway, so I haven't filtered
> > those out.
> 
> What you describe is somewhere between "minor" and not worth reporting.

I think it's worth reporting just to make grep-based QA easier, but as
you say, certainly minor or wishlist.

> But several packages have
>   automake1.11 | automake (>= 1:1.11)

If those are non-trivial to convert, then at least we can say they're
RC-buggy because they fail to build with their dependencies satisfied? :-)

    S