Web lists-archives.com

Bug#857197: ITP: ruby-psych -- A libyaml wrapper for Ruby




Package: wnpp
Severity: wishlist
Owner: Miguel Landaeta <nomadium@xxxxxxxxxx>

* Package name    : ruby-psych
  Version         : 2.2.4
  Upstream Author : Aaron Patterson <tenderlove@xxxxxxxxxx>
* URL             : https://github.com/ruby/psych
* License         : Expat
  Programming Lang: Ruby, C, Java
  Description     : A libyaml wrapper for Ruby

 ruby-psych is a YAML parser and emitter. Psych leverages libyaml for its
 YAML parsing and emitting capabilities. In addition to wrapping
 libyaml, Psych also knows how to serialize and de-serialize most Ruby
 objects to and from the YAML format.
 .
 Psych has been included with the main Ruby implementation since 1.9.2,
 and is the default YAML parser from 1.9.3 and beyond.


 - Although psych is part of the Ruby standard library and is included
   in libruby2.3 package, I propose to package this library in a
   separate package mainly for two reasons:

   * A Ruby developer could want or need a more updated version of
   this library than the one bundle in the standard library. This will
   be provided in ruby-psych package.

   * JRuby depends on psych Java extension. Currently this extension is
   being bundled in jruby package but the right thing is to have this in
   a jruby-psych package.

 - It will be maintained in Debian Ruby Extras Maintainers team.

-- 
Miguel Landaeta, nomadium at debian.org
secure email with PGP 0x6E608B637D8967E9 available at http://miguel.cc/key.
"Faith means not wanting to know what is true." -- Nietzsche

Attachment: signature.asc
Description: Digital signature