Web lists-archives.com

Bug#856674: ITP: unsafe-fences -- Wrapper library around the Java 8 fences API




Package: wnpp
Severity: wishlist
Owner: Miguel Landaeta <nomadium@xxxxxxxxxx>

* Package name    : unsafe-fences
  Version         : 1.0
  Upstream Author : Charles Oliver Nutter <headius@xxxxxxxxxxx>
* URL             : https://github.com/headius/unsafe-fences
* License         : Apache-2.0
  Programming Lang: Java
  Description     : Wrapper library around the Java 8 fences API

 unsafe-fences is a very simple Java library that just provides a shim
 around the Java 8 Unsafe methods used for memory fencing.
 .
 In Java 8, three memory-ordering intrinsics were added to the
 sun.misc.Unsafe class: fullFence, storeFence, and loadFence.
 .
 The main goal of unsafe-fences is to allow code in Java 6 and 7
 to compile those calls with a provided boolean guard.
 .
 This is especially useful for projects like JRuby that support
 several JDK versions but it can be reused by other Java projects as
 well.


- This package is needed as a build dependency for JRuby 9.1.7.0.

- It will be maintained by Debian Java team.

-- 
Miguel Landaeta, nomadium at debian.org
secure email with PGP 0x6E608B637D8967E9 available at http://miguel.cc/key.
"Faith means not wanting to know what is true." -- Nietzsche

Attachment: signature.asc
Description: Digital signature