Web lists-archives.com

Bug#856165: ITP: pupnp-1.8 -- Portable SDK for UPnP Devices, version 1.8




Package: wnpp
Severity: wishlist
Owner: James Cowgill <jcowgill@xxxxxxxxxx>
X-Debbugs-Cc: debian-devel@xxxxxxxxxxxxxxxx, nick@xxxxxxxxxxxx

* Package name    : pupnp-1.8
  Version         : 1.8.0
  Upstream Author : Intel Corporation, Marcelo Roberto Jimenez
* URL             : http://pupnp.sourceforge.net/
* License         : BSD
  Programming Lang: C
  Description     : Portable SDK for UPnP Devices, version 1.8

 The Portable SDK for UPnP Devices (libupnp) provides developers with an
 API and open source code for building control points, devices, and
 bridges that are compliant with Version 1.0 of the Universal Plug and
 Play Device Architecture Specification - see http://www.upnp.org/ for
 specifications.

Version 1.8 has been a work in progress for many years and makes a
number of API changes compared to version 1.6. It's designed to be
co-installable with libupnp 1.6. Upstream are planning to continue
maintaining the 1.6 branch since it's much more widely used. It's
currently only available on GitHub:
https://github.com/mrjimenez/pupnp

pupnp-1.8 is needed for packaging the active fork of mediatomb which I'm
having a look into. This fork solves the current issues facing the
mediatomb package which bundles a heavily patched version of libupnp
containing a number of security issues.

I'm CCing the maintainer for libupnp, although I have a strong feeling
he is MIA.

Thanks,
James

Attachment: signature.asc
Description: OpenPGP digital signature