Web lists-archives.com

Re: apt-get upgrade removing ifupdown on jessie→stretch upgrade




Quoting martin f krafft (2017-02-22 01:06:24)
> Hey,
> 
> I just upgraded a system that had ifupdown from backports.org on it.
> Following cleanup and dpkg --audit etc., I ran
> 
>   root@cymbaline:/etc/apt/sources.list.d# apt-get upgrade
>   Reading package lists... Done
>   Building dependency tree
>   Reading state information... Done
>   Calculating upgrade... Done
>   The following packages will be REMOVED:
>     ifupdown libasprintf0c2 libperl4-corelibs-perl libuuid-perl python-bson python-pymongo
> 
> and indeed, it then went on to remove ifupdown.
> 
> What am I not understanding right here? Shouldn't "apt-get upgrade"
> NEVER EVER EVER EVER remove something?
> 
> Can I find out in hindsight (can't reproduce this) what might have
> happened?

Maybe your ifupdown was flagged as auto-installed, a recent prior APT 
process upgraded to netbase 5.4 (no longer recommending ifupdown), and 
your latest APT process just finished an auto-removal of the no longer 
needed ifupdown for some reason not finalized earlier.

 - Jonas

-- 
 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: signature