Web lists-archives.com

Re: apt-get upgrade removing ifupdown on jessie→stretch upgrade




Hi there,

On Wed, 22 Feb 2017 13:16:27 +0100, David Kalnischkies wrote:
> On Wed, Feb 22, 2017 at 01:06:24PM +1300, martin f krafft wrote:
> > What am I not understanding right here? Shouldn't "apt-get upgrade"
> > NEVER EVER EVER EVER remove something?
[...]
> Fun fact: We have a few reports which request "upgrade" to remove
> packages. You know, automatically installed packages, obsolete ones or
> obviously clear upgrades like exim4 to postfix (or the other way around,
> depending on who reports it). I tend to be against that, but in case of
> need we could still consider that a feature and close bugs… win-win :P

Please do not change the current behavior because...

> Oh, and of course the standard reply: You know, apt does print
> a proposal not an EULA – so you don't have to press 'yes' without
> reading.

...it will break existing practices, e.g.:

 DEBIAN_FRONTEND=noninteractive apt-get upgrade -y

FYI, I would call it a regression.

Thx, bye,
Gismo / Luca

Attachment: signature.asc
Description: Digital signature