Web lists-archives.com

Re: [Pkg-xfce-devel] Processed: reassign 853084 to xfce4-pulseaudio-plugin




Hi Guus,

Quoting Guus Sliepen (2017-01-30 11:29:17)
> On Mon, Jan 30, 2017 at 11:19:32AM +0100, Michael Biebl wrote:
> 
> > > Fredrik, the plugin already recommends pavucontrol (which recommends
> > > pulseaudio) so it should already have been installed unless you manually asked
> > >  not. But right, it might be a good idea to have a direct pulseaudio
> > > recommends .
> > 
> > A pulseaudio plugin without a pulseaudio "Depends" seems rather pointless
> 
> But xfce4 Depends on xfce4-pulseaudio-plugin. Maybe it is better if that
> became a Recommends then?

I'd say yes, but that would be a _different bug, and depends on how that 
metapackage is intended to behave.

For each _direct_ package relation, question is if related packages a 
needed for _all_ uses of the package (depend), there is a rare use 
without it (recommend) or it is only uncommonly needed (suggest).

If it _never_ makes sense to install xfce4 metapackage without also 
installing xfce4-pulseaudio-plugin (i.e. if xfwm4 crashes without that 
plugin existing), then it makes sense to declare strict as a dependency.

Argument above by Michael is that it sounds like it _never_ makes sense 
to install xfce4-pulseaudio-plugin without also installing pulseaudio.

Example: If xfce4-pulseaudio-plugin can somehow communicate (by itself, 
without help from pulseaudio package!) with a remote pulseaudio install 
on a separate host, then it makes sense for the package relation to be a 
recommendation.  If you cannot describe a single use case for this 
package without its related package, then depend on that other package 
(no matter needs of _reverse_ related packages further up the stack!).


 - Jonas

-- 
 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: signature