Web lists-archives.com

Re: git stash damaged?




On 2017-01-19 07:47, Olivier FAURAX wrote:
> When I use "git stash", I get a message saying it is there but not
> executable.
> $ git stash
> fatal: 'stash' appears to be a git command, but we were not
> able to execute it. Maybe git-stash is broken?
> I tested with 2.8.3-1 and 2.8.2-1.
> I checked /usr/libexec/git-core/git-stash and it is a script that has
> proper permissions.
> Can you reproduce? (package: git)

$ file /usr/libexec/git-core/git-stash

and check if it mentions, DOS, BOM, or CRLF line terminators - fix with: 

$ dos2unix -k /usr/libexec/git-core/git-stash

then recheck permissions still executable.

If that's not it, post output of: 

$ ls -Adl .git
$ uname -srvmo
$ git --version
$ file    /usr/libexec/git-core/git-stash
$ ls -l   /usr/libexec/git-core/git-stash
$ getfacl /usr/libexec/git-core/git-stash
$ icacls  `cygpath -w /usr/libexec/git-core/git-stash`

to see if anything looks off.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple