Web lists-archives.com

Windows Path issue with maven/java on cygwin ("/C:/cygwin64/git...")




First time sending an email to the list. Thanks for all the patience of everyone involved.

Due to a work requirement, I'm trying to get the following working:
git - repository successfully downloaded. Original code was written for linux and is java based java - Windows java JDK 8u112 apparently successfully installed and apparently recognized by maven, etc apache-maven - downloaded and apparently installed successfully. All articles I've found with setup instructions stop after having verified that maven is 'working'. Apparently I've succeeded with this.

As you can see from the below text, maven is apparently working and finds my java successfully
$ mvn --version
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T11:41:47-05:00)
Maven home: C:\cygwin64\usr\local\apache-maven-3.3.9
Java version: 1.8.0_112, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.8.0_112\jre
Default locale: en_US, platform encoding: Cp1252
OS name: "windows 10", version: "10.0", arch: "amd64", family: "dos"

Now this is where it gets weird.  When I try the following:
$ mvn compile
in the appropriate git directory everything seems to be working fine until I start seeing this:

.
.
.
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ dataflow-impl ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory C:\cygwin64\git\dfimpl\src\main\resources
[INFO]
[INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @ dataflow-impl ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 202 source files to C:\cygwin64\git\dfimpl\target\classes
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /C:/cygwin64/git/dfimpl/src/main/java/com/gamma/ats/dataflow/utils/GGSNRecordIngestion.java:[5,44] package com.google.cloud.dataflow.sdk.coders does not exist [ERROR] /C:/cygwin64/git/dfimpl/src/main/java/com/gamma/ats/dataflow/utils/GGSNRecordIngestion.java:[6,44] package com.google.cloud.dataflow.sdk.coders does not exist [ERROR] /C:/cygwin64/git/dfimpl/src/main/java/com/gamma/ats/dataflow/utils/GGSNRecordIngestion.java:[7,44] package com.google.cloud.dataflow.sdk.coders does not exist
.
.
.

I can confirm that the files listed exist.
If you type the path as any of the following:
/cygdrive/c/cygwin64/git/  <continue path as appropriate>
C:/cygwin64/git/   <continue path as appropriate>
/git/   <continue path as appropriate>

The issue apparently is the leading "/"

So...my question goes like this:
a) is there something in my configuration which is causing this? (i.e. should I have the linux version of java installed under cygwin or am I missing a setting someplace?) b) is there a fix/hack I can apply to cause the leading / to be a non issue? (i.e. a ln configured a specific way or an alias? I've attempted both but neither seem to have fixed the issue...possibly because I didn't setup the correction properly?) c) has anyone seen anything like this? due to the special characters involved, searching was relatively useless (just about every search found me C/C++/gcc related results...)

Thanks for taking the time to read this.  Any help is appreciated.


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple