Web lists-archives.com

Re: can't run cygwin emacs or XWin Server




On 25/12/2016 23:49, Ken Brown wrote:
On 12/25/2016 5:59 PM, mike wrote:
On 25/12/2016 15:13, Marco Atzeri wrote:
On 25/12/2016 13:55, mike wrote:
I run 32 bit cygwin on a 64 bit machine running Windows 7.

I used to get an XWin Server terminal running bash at startup (logging
into Windows) from which I could run the emacs packaged in cygwin.
After a round of updates I don't get the terminal window at startup and if I try to manually launch it it fails to launch and AFAICT if I try to run emacs from a command prompt I get the native version of emacs that I
also have installed and not the cygwin one.  The shortcut for XWin
Server is

C:\cygwin\bin\run.exe /usr/bin/bash.exe -l -c /usr/bin/startxwin.exe

startxwin.exe doesn't exist any more. It's been replaced by a script /usr/bin/startxwin. And, as Marco said, it doesn't start an xterm automatically any more. See

  https://sourceware.org/ml/cygwin-announce/2015-07/msg00013.html
That is very useful.  Thank you.  I will check it out and report back.

Ken
Mike

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple




--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple