Web lists-archives.com

Re: openssl-devel in openssh README




On 2019-05-26 00:19, Sorin Adrian Savu wrote:
> I had to compile openssh recently, and the README for cygwin is referencing
> openssl-devel package which is obsolete now. I spent some time trying to
> figure this out. Can you please update
> https://github.com/openssh/openssh-portable/blob/85ceb0e64bff672558fc87958cd548f135c83cdd/contrib/cygwin/README#L80
> to mention libssl-devel instead ?

Obsolete package openssl-devel now depends on libssl-devel, if using the current
setup, so you get the correct packages installed and used: look at the package
setup.hint or the setup.ini entry.
Cygwin obsolete packages are most similar to other distros virtual packages, but
they can require specific dependencies and/or versions be installed: this avoids
updating dependencies and docs just because dependency package names change.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple