Web lists-archives.com

Curl-7.64.1-1 not returning any data




About two months ago curl stopped working in our cygwin installations.  It is unclear
what has changed apart from periodic cygwin and windows updates.  I have tried
re-installing cygwin.  I have tried installing cygwin on a different computer.  The
result is the same -- not working.  Curl does work as expected on our Linux systems.
Invoke-WebRequest (PowerShell) continues to work even on the same systems where
curl (Cygwin) does not.  Here is an example:

> curl -v -o junk.html www.google.com
* STATE: INIT => CONNECT handle 0x600077108; line 1361 (connection #-5000)
* Added connection 0. The cache now contains 1 members
> ls -l junk.html
/bin/ls: cannot access 'junk.html': No such file or directory

How can I troubleshoot this to find out what is wrong?

The output of cygcheck is attached with usernames and domain names redacted.
-- 
Wes Barris

This email and any files transmitted with it are confidential and intended solely for the use of the addressee. If you are not the intended addressee, then you have received this email in error and any use, dissemination, forwarding, printing, or copying of this email is strictly prohibited. Please notify us immediately of your unintended receipt by reply and then delete this email and your reply. Cobb-Vantress, Inc. and its subsidiaries and affiliates will not be held liable to any person resulting from the unintended or unauthorized use of any information contained in this email or as a result of any additions or deletions of information originally contained in this email.

Attachment: cygcheck.out
Description: cygcheck.out

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple