Web lists-archives.com

Re: libxml2-devel package: missing dependency libiconv-devel




On Sun, 2019-05-19 at 14:21 +0200, Simon Sobisch wrote:
> Seen when using a fresh CI environment with only libxml2-devel added by
> cygwin setup on running a configure script:
[snip]
> As libxml2-devel provides a header that has a hard dependency on iconv.h
> it should also include a dependency libiconv-devel in its "requires"
> attribute of the package-version-release.hint (I did not found the
> actual hint file when looking at the package list[1]) and likely also
> include the necessary options in the shipped pkg-config file.

Thanks; fixed in git, and soon on sourceware.

--
Yaakov



--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple