Web lists-archives.com

Re: How to install gcc and g++ 6 on cygwin which are not on the setup.exe




Doug Henderson, Saturday, May 18, 2019 01:12 AM, wrote...
>On Wed, 15 May 2019 at 14:58, Jose Isaias Cabrera <> wrote:

>You seem to be having some difficulty getting an older version of the
>compiler running. Perhaps it might be useful to go back to the
>beginning and see if there is an alternative solution.

That is how I started.  But, when I started to compile Bedrockdb, there were too many compiler errors.  Since the source is gcc-6 compatible, the version I downloaded from cygwin was 7.4.0-01. So, I didn't want to go that way, since the source would have to be changed.

>What kind of compiler errors are you getting? Post the gcc command
>line and a sample of the errors to see if anyone has suggestions for
>resolving them in gcc7.x.
I could try this next, but I would need you to be there. :-)  Just kidding.

>
>HTH
>Doug

Thanks, Doug.  I have installed gcc-6,

e608313@HOR711318E ~/gcc/gcc-6.4.0
$ gcc --version
gcc (GCC) 6.4.0
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


e608313@HOR711318E ~/gcc/gcc-6.4.0
$ which gcc
/usr/local/bin/gcc

So, now I will start to compile Bedrockdb.  Thanks for all your help, folks.

josé

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple