Web lists-archives.com

Re: How to install gcc and g++ 6 on cygwin which are not on the setup.exe




On Wed, 15 May 2019 at 14:58, Jose Isaias Cabrera <> wrote:

> Is there a way an easy way to install gcc-6 and g++-6 on cygwin?  I just uninstalled v7.4.x or whatever was on the setup.  I am trying to build a software and gcc 7.x and g++ 7.x is giving too many compiler errors.  I want to try 6 to see if these errors minimize or go away.  Thanks for the help.

You seem to be having some difficulty getting an older version of the
compiler running. Perhaps it might be useful to go back to the
beginning and see if there is an alternative solution.

What kind of compiler errors are you getting? Post the gcc command
line and a sample of the errors to see if anyone has suggestions for
resolving them in gcc7.x.

You can use the help option to get more information about a lot of topics.

 | --help={common|optimizers|params|target|warnings|[^]{joined|separate|undocumented}}[,...].
 |                          Display specific types of command line options.

You can use gcc options to determine which version of C the compiler
will compile. There are also options to control which warnings are
generated, and possibly turned into errors by a -Werror option.

Use the info command:

info gcc

and enter the info search command: (CR=press enter)

/-std=CR

to find the relavent section.

HTH
Doug

-- 
Doug Henderson, Calgary, Alberta, Canada - from gmail.com

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple