Web lists-archives.com

Re: How to install gcc and g++ 6 on cygwin which are not on the setup.exe




Csaba Ráduly, on Thursday, May 16, 2019 05:47 PM, wrote...

>Hi José,
Hi Csaba.

>Building GMP, MPFR and MPC seems like overkill. The following packages are
>available for Cygwin:
>
>libgmp-devel 6.1.2
>libmpfr-devel 4.0.2
>libmpc-devel 1.1.0
Yep, tried these, and for some reason, when I ran ./configure to build GCC6, it told me that I needed those libraries.  The error message was,

[clip]
checking for the correct version of gmp.h... no
configure: error: Building GCC requires GMP 4.2+, MPFR 2.4.0+ and MPC 0.8.0+.
[clip]

So, I said, let me just do this, and there will not be any excuse. :-)

>BTW, if you're trying to build Bedrockdb, G++ 6 is likely unable to help you.
>The Bedrockdb developers seem to suffer a bit from "all the world is Linux"
>syndrome.

Yeah.  Seems like the whole world is thinking like that. :-)  I do have linux boxes at home, but I also have windows.  Thanks for all the help.  I will let you know the outcome.  Already built GMP and MPFR.  Now running 'make' on MPC.  This one should take less time than MPFR.  GMP took a good 3 hours just to run make.  YIKES.  Later.

josé

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple