Web lists-archives.com

Re: How to install gcc and g++ 6 on cygwin which are not on the setup.exe




Hi José,

On 16/05/2019 18:47, Jose Isaias Cabrera wrote:

Csaba Raduly, on Thursday, May 16, 2019 03:36 AM, wrote...
 >
 >Hi José,

 >Another option is to download the source and build it yourself.

Yep.  Going with this option.  Seems the most logical one for now.  After running ./configure, got this error,

configure: error: Building GCC requires GMP 4.2+, MPFR 2.4.0+ and MPC 0.8.0+.

So, now I am building GMP, then MPFR and then MPC.  It's going to be a lot of work, so... :-)  :Let's hope is worth it.  Thanks for your help.

Building GMP, MPFR and MPC seems like overkill. The following packages are available for Cygwin:

libgmp-devel 6.1.2
libmpfr-devel 4.0.2
libmpc-devel 1.1.0


BTW, if you're trying to build Bedrockdb, G++ 6 is likely unable to help you. The Bedrockdb developers seem to suffer a bit from "all the world is Linux" syndrome.


Csaba
--
You can get very substantial performance improvements
by not doing the right thing. - Scott Meyers, An Effective C++11/14 Sampler
So if you're looking for a completely portable, 100% standards-conformat way
to get the wrong information: this is what you want. - Scott Meyers (C++TDaWYK)

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple