Web lists-archives.com

Re: Update libgc?




Hi Ken,

On Sat, Mar 30, 2019 at 12:34 AM Ken Brown <kbrown@xxxxxxxxxxx> wrote:
> I'm getting a crash in cyggc-1.dll when building asymptote.

It would be great if you can report this to the upstream because I
think the 7.x series is still being supported and there are new
releases now and then, so it would be nice to have that bug fixed in
7.x as well.

> Any chance you could update libgc to a later release?  I built and installed libgc-8.0.2, which
> is the latest release available at http://www.hboehm.info/gc/gc_source/, and the
> crash didn't occur.

Yes, I will look into that. Upstream even made a PR to my cygport file
a few days ago: https://github.com/andyli/libgc-cygwin/pull/7
I'm checking with him about backward compatibility.

Best,
Andy

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple