Web lists-archives.com

Re: cat.exe failing silently with exit status 3




On 2019-03-26 21:55, Chris Wagner wrote:
> Hi all.  A few days ago I noticed that cat.exe was failing without printing any
> output or errors and exiting with status 3.  I tried rebooting, updating my
> Cygwin, even a fresh install of Base only.  I removed all recently installed
> Windows software and nothing changed.  What's truly strange is that it seems to
> be only cat that is broken.  Hilariously tac works fine.  I can even emulate cat
> with "tac foo |tac".
> 
> Whatever changed, Cygwin, coreutils, or Windows, I can't narrow it down.  I'm on
> Windows 7 SP1 and my Cygwin is up to date (3.0.4-1).  Coreutils is 8.26-2.
> 
> I launched cat with strace and it always ends with:
> --- Process 3928, exception c0000005 at 0000000000000000
> --- Process 3928 thread 10476 exited with status 0xc0000001
> --- Process 3928 exited with status 0xc0000001
> 
> The output is vastly truncated compared to what tac shows.  The thread dies
> immediately instead of loading the environment, etc.
> 
> I attached the strace output of cat and tac along with the sysinfo and cygcheck
> output.  I hope this is just something simple overlooked in the latest version
> of cat.

Shows FAST_CWD error:
"Cygwin WARNING:
  Couldn't compute FAST_CWD pointer.  This typically occurs if you're using
  an older Cygwin version on a newer Windows.  Please update to the latest
  available Cygwin version from https://cygwin.com/.  If the problem persists,
  please see https://cygwin.com/problems.html";

This may be because previous setup run did not complete because a Cygwin process
was still active.
Try shutting down all Cygwin processes, checking for no Cygwin processes
running, then downloading and rerunning setup, and reinstalling cygwin and
coreutils packages.

If that does not clean everything up, check you have nothing matching /bin/*.new
or /etc/postinstall/[!0z][!pqrst][!_]*.*sh left over by setup, and
/var/log/setup.log.full looks clean with normal completion.

You might want to strip the Seagate and GPAC stuff from your Cygwin path as it
could be BLODA, or add CYGWIN_NOWINPATH=1 to your env to strip Windows paths.

If you still have problems, run "cygcheck cat" and post the output.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple