Web lists-archives.com

Re: [PATCH] default ps -W process start time to system boot time when inaccessible, 0, -1




On 2019-03-24 02:18, Achim Gratz wrote:
> Brian Inglis writes:
>> Are there non-startup system processes for which boot time is misleading?
>> If you need the truth use wmic, procexp64, or run ps in an elevated shell.
> 
> I don't seem to get my point across.  I'm fine with getting no start
> time value when that ps wasn't able to obtain that information.  If we
> have to use magic values to convey that information for one reason or
> another, then I'd rather opt for one that is obviously pulled out of
> thin air than for one that I have to compare to some other stuff before
> that becomes clear.

[Cross posting to Cygwin list as this is a more general discussion IMO]

Boot time is neither magic nor pulled out of thin air.
Checking *my* system processes using wmic queries and elevated powershell
scripts, the boot time is at most a few seconds off from process start times
from other sources.
I understand that other systems may run processes where that is not the case.
Please explain why you think this is misleadingly not useful, or where or which
processes have unvailable start times that are not very close to boot time.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple