Web lists-archives.com

RE: can't access remote shares when using ssh with rsa key - passwd -R / set(e)uid / LogonUser is not working as expected




When you login with stored password, Cygwin performs the same LogonUser call as if you login with password, so the same user token is generated.

Off the top of my head I don't know why it shouldn't work for you.  You sure you have the correct password stored?  When you login and call `id', what does it print?  Does it contain the "interactive" group or the "network" group?  If the latter, then the internal LogonUser call performed with stored password failed for some reason.


Corinna

--
Corinna Vinschen
Cygwin Maintainer

---------------------------------------------------------------------------------------

Yes, I'm sure I used the correct password, I use it all the time and I also tried running passwd -R multiple times in case I entered it wrongly.
I'm not sure what are "interactive" & "network" groups - do you mean literally groups called network & interactive?
Either way - I'm always getting a group named "interactive" among other groups - either with password ssh or with RSA - never "network"
I do have some different groups when running id - comparing password ssh and RSA ssh.
Also, when I run mkpasswd -d when I log in with password, it generates users from the domain, comparing RSA ssh that generates only a few entries unrelated to my domain..

I think the same as you (also mentioned in the email title :) ) that the LogonUser call doesn't work as expected. Is there a way to verify it? Any logs I can check?
Would it help if I'll send the different groups I'm getting?

Thanks!