Web lists-archives.com

Re: Cygwin-3 and the Bleeding Edge




On 3/4/2019 7:05 AM, KARL BOTTS wrote:
> So:  Assume for the moment that the latest git package release on the mirrors,
> has been built against cygwin-3 base.  Am I reasonably safe to assume it will
> still work with cygwin-2.11.2?  Does this generalize to all, or at least most,
> other packages?

There's no general rule.  cygwin-3.0.0 introduced some new APIs.  Newly 
built packages may or may not make use of these.  If they do, they won't 
work with an earlier version of cygwin.

Ken