Web lists-archives.com

Request for rebuiding Wxwidget 3.0 to avoid ABI mismatch warning




Dear Yaakov Selkowitz

WxWidget on Cygwin may be built by old compiler.
This caused ABI mismatch warining on gnuplot for Cygwin
in plotting on wxt terminal.

gnuplot> pl x
07:54:00: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).



The warning can be avioded if I attach patch to gnyuplot source.


--- a/src/wxterminal/wxt_gui.cpp 2018-03-17 07:26:21.926092000 +0900
+++ b/src/wxterminal/wxt_gui.cpp 2018-03-17 07:28:56.748497600 +0900
@@ -88,7 +88,7 @@
  * or multi-threaded operation.
  */
 
-
+#define __GXX_ABI_VERSION 1009
 /* define DEBUG here to have debugging messages in stderr */
 #include "wxt_gui.h"



However, if wxwidget are re-built using the current compiler this patch to gnuplot source
can be avioided.

Please consider the update.

Tatsuro


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple