Web lists-archives.com

Re: cygwin 3.0.1-1 breaks my sshd install




I’m seeing a similar issue. Will try using localsystem. 

> On Feb 21, 2019, at 6:43 AM, Houder <houder@xxxxxxxxx> wrote:
> 
>> On Thu, 21 Feb 2019 11:09:11, Corinna Vinschen  wrote:
>> 
>> I managed it today already but I'm somewhat stumped.
>> 
>> I ran ssh-host-config and let the script install a new local account
>> "test_server" to use for the sshd service.  I started the service and
>> tried to login with a local account and it just worked out of the box.
> 
> This is my case: using local accounts only.
> 
> Reminder: sshd did work w/ 2.11.2 ...
> (and it works now in 3.0.1 after replacing cyg_server w/ SYSTEM (*) )
> 
> Way back I started using cyg_server because "csih" forced me to create
> this privileged account (W7!).
> 
> I studied "csih" (cygwin-service-installation-helper.sh) again ...
> 
> 64-@@# editrights -u cyg_server -l
> SeAssignPrimaryTokenPrivilege
> SeCreateTokenPrivilege
> SeServiceLogonRight
> SeDenyInteractiveLogonRight
> SeDenyRemoteInteractiveLogonRight
> 
> Compared to "csih", the SeTcbPrivilege privilege was missing. I am not
> in the habit of messing with privileges ...
> 
> Consequently, like you, I am stumped too :-)
> 
> (*) after "moving" the sshd service from cyg_server to SYSTEM, I also
> changed the ownership of /var/empty and /etc/ssh* (to SYSTEM) ...
> 
> Next, I disabled the cyg_server and sshd accounts. ssh still works.
> 
> Henri
> 
> 
> --
> Problem reports:       http://cygwin.com/problems.html
> FAQ:                   http://cygwin.com/faq/
> Documentation:         http://cygwin.com/docs.html
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
> 

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple