Web lists-archives.com

Re: portable use of dos2unix WAS: Re: textmode for stdout, what is "correct" now?




On 2/15/19 10:00 PM, Corinna Vinschen wrote:
> On Feb 15 20:33, Michael Haubenwallner wrote:
>> On 2/15/19 7:35 PM, Andrey Repin wrote:
>>> I have a different question though. The commands you presented in the OP
>>> look like you aren't using Cygwin-suppied OpenSSL binary.
>>
>> This is true: The Cygwin distro does provide openssl-1.0.2p, but I'm building
>> the *portable* Gentoo Prefix distro on Cygwin, with openssl-1.1.1a already.
>> But whenever the Cygwin distro would bump to openssl-1.1, the same problem
>> would arise there as well, just becomes noticed much later probably.
> 
> Does OpenSSH build with OpenSSL 1.1.1a these days?  If so, we might
> want to switch OpenSSL finally, too.

Well, OpenSSH-7.9_p1 maybe does, according to https://bugs.gentoo.org/592578

But there's a bunch of other packages that still don't, at least within Gentoo:
https://bugs.gentoo.org/showdependencytree.cgi?id=592438&maxdepth=1

> Btw., Michael, maybe you're interested to become Cygwin OpenSSL
> maintainer?

Uhm, here I have to decline, as I don't really care about the openssl version
in the Cygwin distro.  Providing headsup here and there upon breakage really
is something different.

Sorry, but thank you for the confidence,
/haubi/

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple