Web lists-archives.com

Re: Bug: No json support anymore in Ruby 2.3.6




Hey all,
looking at
http://mirrors.kernel.org/sourceware/cygwin/x86_64/setup.ini
I see that there is a ruby-json package:

@ ruby-json
sdesc: "Ruby JSON module"
...

but ruby does not currently depend on ruby-json:

@ ruby
sdesc: "Interpreted object-oriented scripting language"
...
requires: cygwin libcrypt0 libdb5.3 libffi6 libgcc1 libgdbm4 libgmp10
libopenssl100 libreadline7 libssp0 libyaml0_2 ruby-did_you_mean
ruby-psych ruby-rdoc rubygems zlib0
...
depends2: cygwin, libcrypt0, libdb5.3, libffi6, libgcc1, libgdbm4,
libgmp10, libopenssl100, libreadline7, ruby-did_you_mean, ruby-psych,
ruby-rdoc, rubygems, zlib0

Maybe rubygems should, let's see:

@ rubygems
sdesc: "Ruby module management system"
ldesc: "A centralized Ruby extension management system, similar to Perl's CPAN"
category: Ruby
requires: ca-certificates ruby ruby-builder ruby-io-console
ruby-minitest ruby-minitest4 ruby-psych ruby-rake ruby-rdoc
...
depends2: ca-certificates, ruby, ruby-builder, ruby-io-console,
ruby-minitest, ruby-psych, ruby-rake, ruby-rdoc

I am not a cygwin developer, but it does kind of sound like the rubygems package
might want to depend on the packages required to provide the 'default'
gems from stdgems.org.

The right way to phrase that request would be as a patch :-) if a
cygwin ruby user who needs it has the time and energy to get into
cygwin development.
- Dan

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple