Web lists-archives.com

Re: Setup missing installed packages




Greetings, Lemke, Michael  ST/HZA-ZIC2!

>>> I was just about to update my Cygwin installation when setup would
>>> list only a fraction of my installed packages. For instance git is 
>>> missing but I have it installed. setup_version is 2.893 and running 
>>> it with -v it tells there are 69 packages installed. But
>>>
>>> $ wc /etc/setup/installed.db
>>>    835  2504 36779 /etc/setup/installed.db
>>>
>>> and I also see all these tar files in the installation directory. This
>>> is a 32bit installation on Win10 64bit.
>>>
>>> What is going on, how can I debug this?
>>>
>>
>>69 packages seems a minimal installation.
>>May be you have more than one Cygwin installed ?
>>
>>Double check the proposed installation directory from setup

> Thanks, I did and I can't find anything wrong. Where does setup.exe gets
> the information from? I tried several versions, the current official one,
> the new snapshot and something older I have lying around. They all do
> this. They are in my distribution directory with all the Cygwin downloads
> and all show the correct location of distribution directory and installation
> directory. Some junk in the registry?

did you try
> --
> Problem reports:       http://cygwin.com/problems.html

?


-- 
With best regards,
Andrey Repin
Tuesday, October 23, 2018 20:20:24

Sorry for my terrible english...


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple