Web lists-archives.com

Re: RE: Setup missing installed packages




On Tuesday, October 23, 2018 10:55 AM Michael Lemke wrote:
[snip]

> Thanks, I did and I can't find anything wrong. Where does setup.exe gets
> the information from? I tried several versions, the current official one,
> the new snapshot and something older I have lying around. They all do
> this. They are in my distribution directory with all the Cygwin downloads
> and all show the correct location of distribution directory
> and installation directory. Some junk in the registry?

uhm ...

Data stored in the registry (Cygwin_root, local_repo):

For a 32-bits instance of Cygwin,
    see HKEY_LOCAL_MACHINE\SOFTWARE\Cygwin

For a 64-bits instance of Cygwin,
    see HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Cygwin

.. but if you are using a fixed location for your Cygwin_root and
for your local_repo (distribution directory), why not:

 - create a shortcut to the setup executable ...
 - and add -n -R x:/your_root -l x:/_your_local_repo as arguments
   to the invocation of the executable
   ( x = your drive letter)

and force yourself to use that shortcut?

That would override any default (either by the setup executable or
by you in the past).

.. and save you the trouble of posting to this list.

Regards,
Henri


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple