Web lists-archives.com

RE: Setup missing installed packages




On Tuesday, October 23, 2018 10:55 AM Michael Lemke wrote:
>On Mon, 22 Oct 2018 10:57:46 -0700 (PDT) Marco Atzeri wrote:
>>Am 22.10.2018 um 18:50 schrieb Lemke, Michael:
>>> I was just about to update my Cygwin installation when setup would 
>>> list only a fraction of my installed packages. For instance git is 
>>> missing but I have it installed. setup_version is 2.893 and running 
>>> it with -v it tells there are 69 packages installed. But
>>>
>>> $ wc /etc/setup/installed.db
>>>    835  2504 36779 /etc/setup/installed.db
>>>
>>> and I also see all these tar files in the installation directory. This
>>> is a 32bit installation on Win10 64bit.
>>>
>>> What is going on, how can I debug this?
>>>
>>
>>69 packages seems a minimal installation.
>>May be you have more than one Cygwin installed ?
>>
>>Double check the proposed installation directory from setup
>
>Thanks, I did and I can't find anything wrong. Where does setup.exe gets
>the information from? I tried several versions, the current official one,
>the new snapshot and something older I have lying around. They all do
>this. They are in my distribution directory with all the Cygwin downloads
>and all show the correct location of distribution directory and installation
>directory. Some junk in the registry?

Nevermind, I found it. setup.exe chose c:\cygwin as installation directory
which is wrong for my installation. I don't know, though, why it picked
this directory. Anyway, if I enter the correct location manually everything
is fine. Sorry for the noise.

Michael

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple