Web lists-archives.com

Re: Cygwin fails to utilize Unicode replacement character




On Sep  7 12:34, Thomas Wolff wrote:
> On 07.09.2018 10:17, Corinna Vinschen wrote:
> > On Sep  6 09:01, Corinna Vinschen wrote:
> > > On Sep  5 18:35, Steven Penny wrote:
> > > > On Wed, 5 Sep 2018 22:14:59, Corinna Vinschen wrote:
> > > > > OTOH, in my testing this only occurs for DejaVu Sans Mono.  I installed
> > > > > Liberation Mono and Noto Mono as well and the above problem never occurs
> > > > > with them.  Weird.  I'm about to let this slip as a font bug.
> > > > as you prob know ive been testing on W7. i found a W10 virtual machine here:
> > > > 
> > > > http://developer.microsoft.com/microsoft-edge/tools/vms
> > > > 
> > > > but it requires 4GB RAM just for the image. since i only have 4GB total on my
> > > > system the image wont load into virtualbox.
> > > > 
> > > > i can see about upgrading my system - but i wont bother if you are intent on
> > > > wiping your hands of this anyway
> > > > 
> > > > let me know - thanks
> > > https://cygwin.com/ml/cygwin-cvs/2018-q3/msg00054.html
> > I created new developer snapshots for testing.  Please give the latest from https://cygwin.com/snapshots/ a try.
> Consolas: invalid encoding: hollow box, unknown glyph: boxed question mark
> Lucida Console: invalid encoding: medium shade, unknown glyph: hollow box
> so far it's fine, but:
> Raster Fonts: output of invalid encoding hangs cygwin...
> 
> > This will be my last action for the next 4 weeks though.  I'll be back in October.
> I'll try to check the code.

Looks like s/ANSI_CHARSET/DEFAULT_CHARSET/ does the trick


Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat

Attachment: signature.asc
Description: PGP signature