Web lists-archives.com

Re: "build-essential" metapackage [WAS: FW: gecko Segmentation fault when compiling]




Greetings, cyg Simple!

> On 8/29/2018 6:01 AM, Andrey Repin wrote:
>> 
>> I think we need a "build-essential" metapackage.
>> 

> I would suggest base-devel as the name of the metapackage.

build-essential is a name of a well-known Debian metapackage.

> But what exactly should that include?

Package: build-essential
State: not installed
Version: 12.1ubuntu2
Priority: optional
Section: devel
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@xxxxxxxxxxxxxxxx>
Architecture: amd64
Uncompressed Size: 20,5 k
Depends: libc6-dev | libc-dev, gcc (>= 4:5.2), g++ (>= 4:5.2), make, dpkg-dev (>= 1.17.11)

In case of Cygwin, it should probably include autotools and cygport.

> Should there be more than one metapackage that adds more complex tools?

IDK, I'm not a developer myself.


-- 
With best regards,
Andrey Repin
Thursday, August 30, 2018 3:23:38

Sorry for my terrible english...


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple