Web lists-archives.com

Strange git issue with a particular repo




Hi All.

Please cc me on responses, as I don't subscribe to the list.

I'm using a 64 bit install on Windows 10. I just now did an update
and it did not help.  The problem is with a particular repo only.
(Or at least, I only see it with this particular repo.) On Linux, do:

	git clone git://github.com/arnoldrobbins/bwk-awk
	cd bwk-awk
	git status

You should see something like this:

	$ git clone git://github.com/arnoldrobbins/bwk-awk
	Initialized empty Git repository in /u/arnold/bwk-awk/.git/
	remote: Counting objects: 463, done.
	remote: Compressing objects: 100% (16/16), done.
	remote: Total 463 (delta 1), reused 6 (delta 1), pack-reused 444
	Receiving objects: 100% (463/463), 5.06 MiB | 1.77 MiB/s, done.
	Resolving deltas: 100% (79/79), done.
	$ cd bwk-awk
	$ git status
	# On branch master
	nothing to commit (working directory clean)

On Cygwin, something strange happens instead:

	$ git clone git://github.com/arnoldrobbins/bwk-awk
	Cloning into 'bwk-awk'...
	remote: Counting objects: 463, done.
	remote: Compressing objects: 100% (16/16), done.
	remote: Total 463 (delta 1), reused 6 (delta 1), pack-reused 444
	Receiving objects: 100% (463/463), 5.06 MiB | 2.33 MiB/s, done.
	Resolving deltas: 100% (79/79), done.
	$ cd bwk-awk
	$ git status
	On branch master
	Your branch is up to date with 'origin/master'.

	Changes not staged for commit:
	  (use "git add <file>..." to update what will be committed)
	  (use "git checkout -- <file>..." to discard changes in working directory)

		modified:   regdir/Compare.T
		modified:   regdir/T.delete
		modified:   regdir/T.getline
		modified:   regdir/T.redir
		modified:   regdir/T.split
		modified:   regdir/T.sub

	no changes added to commit (use "git add" and/or "git commit -a")

The "modified" files are from an earlier commit. Doing git reset --hard has
no effect.

On cygwin:

	$ git --version
	git version 2.17.0

On Linux:

	$ git --version
	git version 1.7.1

But it also works OK on a Linux system with git 2.17.1.

Any help would be appreciated. I hope that you can reproduce it.

Thanks!

Arnold

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple