Web lists-archives.com

Cygwin Tcl iwidgets4.0.1 has package find Errors




Cygwin Tcl iwidgets Issue

I installed the following latest Cygwin packages on 03-Aug-2018:
4.0.3-1  tcl-itcl
4.0.1-1  tcl-itk
4.0.1-3  tcl-iwidgets

I created a small Tk/Widgets test program including:

# Include incr Widgets extension
package require Iwidget

iwidgets::combobox .combobox \
-foreground $color(text_foreground) \
-background $color(window_background) \
-labelpos w \
-editable true \
-labeltext "Views" \
-dropdown true

When trying to run this program, I got the following Error from
iwidgets4.0.1:
Error in startup script: can’t find package Itcl 3.3

Looking at lib/iwidget4.0.1/iwidgets.tcl file, I see the following
package require statements:

package require itcl 3.3
package require itk 3.3

This 3.x packages are NOT present in /lib directory.

I updated the iwidgets.tcl file to use the installed 4.0.x packages.
This resulted in an Application Error when trying to use the
ComboBox.

The current Cygwin iwidget.tcl installed package does not seem correct.

Edmond Knappe
efknappe3@xxxxxxxxx

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple