Web lists-archives.com

Re: KDE Konsole does not display the special characters




Michel,

There is a "[" missing in Formats] your reply above, chedk that the
file on disk is OK.

If making   Format]   --->   [Format]   doesn't work, put the old file
back and see if Konsole starts using it.

Also check that the read permissions and ownership on the
.config/plasma-localerc file are correct after editing.

Keith


On Fri, Aug 3, 2018 at 2:22 AM, Michel Dubois <dubois.michel@xxxxxxxxx> wrote:
> Thanks to answer
>
> I filled the file  .config/plasma-localerc like this :
> Formats]
> LANG=fr_FR.UTF-8
> LC_CTYPE=" fr_FR.UTF-8"
> LC_NUMERIC="fr_FR.UTF-8"
> LC_TIME="fr_FR.UTF-8"
> LC_COLLATE="fr_FR.UTF-8"
> LC_MONETARY="fr_FR.UTF-8"
> LC_MESSAGES="fr_FR.UTF-8"
> useDetailed=true
>
> [Translations]
> LANGUAGE=fr_FR
>
> I restarted cywin and start_kdeinit doesn't start any more. When I remove
> the file .config/plasma-localerc start_kdeinit works.
> Regards,
>
>
> Le jeu. 2 août 2018 à 21:09, Brian Inglis <Brian.Inglis@xxxxxxxxxxxxxxxxxx>
> a écrit :
>
>> On 2018-08-02 08:49, Michel Dubois wrote:
>> > I went to install konsole KDE package on cygwin. I was surprised this
>> > terminal  is not managing well the accent or other special character and
>> > replace them by "?"
>> >  ~ > ls
>> > Desktop  Documents  GIT_workdir  Images  Mod��les  Musique  Public
>> > T��l��chargements  Vid��os
>> > ~ > locale
>> > LANG=fr_FR.UTF-8
>> > LC_CTYPE="fr_FR.UTF-8"
>> > LC_NUMERIC="fr_FR.UTF-8"
>> > LC_TIME="fr_FR.UTF-8"
>> > LC_COLLATE="fr_FR.UTF-8"
>> > LC_MONETARY="fr_FR.UTF-8"
>> > LC_MESSAGES="fr_FR.UTF-8"
>> > LC_ALL=
>> > ~ > env | grep LANG
>> > LANG=fr_FR.UTF-8
>> > LANGUAGE=
>> > On bash terminal of cygwin or QtTerminal  I don't have this problem
>> > May you help  ?
>>
>> Web says - you should be able to set it with right-click/encoding/... then
>> exit
>> and restart konsole; OR likely mismatch between one of:
>>
>> $ cat .config/plasma-localerc
>> [Formats]
>> LANG=en_CA.UTF-8
>> LC_CTYPE="en_CA.UTF-8"
>> LC_NUMERIC="en_CA.UTF-8"
>> LC_TIME="en_CA.UTF-8"
>> LC_COLLATE="en_CA.UTF-8"
>> LC_MONETARY="en_CA.UTF-8"
>> LC_MESSAGES="en_CA.UTF-8"
>> useDetailed=true
>>
>> [Translations]
>> LANGUAGE=en_CA:en_GB:en
>>
>> OR
>>
>> $ cat .kde/env/setlocale.sh
>> export LANG=en_CA.utf8
>> export LANGUAGE=en_CA:en_GB:en
>>
>> and profile: change and restart KDE.
>>
>> --
>> Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada
>>
>> --
>> Problem reports:       http://cygwin.com/problems.html
>> FAQ:                   http://cygwin.com/faq/
>> Documentation:         http://cygwin.com/docs.html
>> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
>>
>>
>
> --
> -----------------------------------------------------------
> Michel Dubois
>
> --
> Problem reports:       http://cygwin.com/problems.html
> FAQ:                   http://cygwin.com/faq/
> Documentation:         http://cygwin.com/docs.html
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple