Web lists-archives.com

Issue running PowerShell code on Windows Machine from Linux machine using Cygwin




 Hi Team,

I am having issue while establishing a ssh connection from Linux to Windows
machine using Cygwin. My powershell script works when I run it from Linux
using ssh connection(Cygwin) to Windows  and manually enter my passowrd.
But whn I use public key to authenticate my user(making a password less
connection), it fails. Is it a bug with CYgwin?

Below is the step by step explantion-


1. Sample
Code
I have put on Windows machine. This machine has Cygwin installed on it

+++++++++++++
:
+++++++++++

echo "Hello World!"
import-module ActiveDirectory
get-adcomputer -Filter * |select Name|select -first 10
+++++++++++++++++++++++++


2. When I run
this code
 from Linux machine using Cygwin WITHOUT enabling password-less connection,
It asks for password
of Windows machine and after entering the password it
 execute
s
 like a charm. See below-

+++++++++++++++++++++++

shekhar@LinuxBox:~$ ssh shekhar@xxxxxxxxxxxxxxxxxxxxx 'powershell
"C:/scripts/abc.ps1"'
shekhar@xxxxxxxxxxxxxxxxxxxx's password:

Hello World!

Name
----
Server1
Server2
Server3
Server4

++++++++++++++++++++++++

3. Now I generate an ssh-key on Linux for user shekhar and copy it on
Windows machine to make a password less connection.

++++++++++++++++++++++++++++++

shekhar@LinuxBox:~$ ssh-copy-id shekhar@xxxxxxxxxxxxxxxxxxxxx
shekhar@WindowsBox's password:
Now try logging into the machine, with "ssh 'shekhar@xxxxxxxxxxxxxxxxxxxxx'",
and check in:

  .ssh/authorized_keys

to make sure we haven't added extra keys that you weren't expecting.
++++++++++++++++++++++++++++++++


4. Now I run the same script again. Now it doesn't asks a password makes a
connection with Windows box and display Hello world(first line of code) but
fails on the second line

+++++++++++++++

shekhar@LinuxBox:~$ ssh shekhar@xxxxxxxxxxxxxxxxxxxx  'powershell
"C:/scripts/abc.ps1"'
Hello World!
WARNING: Error initializing default drive: 'Unable to contact the server.
This
may be because this server does not exist, it is currently down, or it does
not
 have the Active Directory Web Services running.'.
Get-ADComputer : Unable to contact the server. This may be because this
server
does not exist, it is currently down, or it does not have the Active
Directory
Web Services running.
At C:\scripts\abc.ps1:3 char:15
+ get-adcomputer <<<<  -Filter * |select Name|select -first 10
    + CategoryInfo          : ResourceUnavailable: (:) [Get-ADComputer],
ADSer
   verDownException
    + FullyQualifiedErrorId : Unable to contact the server. This may be
becaus
   e this server does not exist, it is currently down, or it does not have
th
  e Active Directory Web Services running.,Microsoft.ActiveDirectory.Managem
 ent.Commands.GetADComputer
++++++++++++++++++

Thanks in advance.

Regards,
Shekhar

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple