Web lists-archives.com

Re: fork issue on Cygwin x86_64 2.10.0-1




the rebaseall sometimes do not work because files are lock()ed by windows. So triple, no, quadruple check you have all cygwin processes stopped, including possible "cygrunsv" services, before you even let it play with autorebase.

You can run again the cygsetup and make it reinstall the offending package, so that it runs rebase to it -- but it would be for naught if you still have stuff locking the rebased packages.

This issue is really the thorn by cygwin's side for a long time... always, maybe?

I wonder if this address limitation was just a "quick implementation" to be able to interface unix system calls to windows, or if it really is impossible to have cygwin's memory allocation be able to dynamically allocate stuff around the system without the need to reserve those base addresses and avoid conflicts, etc.


On 7/19/2018 9:25 PM, Tatsuro MATSUOKA wrote:
cygwin1.dll 2.10.0-1

At log in bash cygwin does not work due to the below
0 [main] bash 9888 child_info_fork::abort: C:\cygwin64\bin\cygncursesw-10.dll: Loaded to different address: parent(0x80000) != child(0x150000)

I execute setup_x86_64.exe, execute autorebase.dash and reboot PC but the problem was not solved.

Any suggestions?

Tatsuro

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple




--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple